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Abstract
STAR SAGA: ONE Beyond The Boundary and its sequel are members of a class of computer game that is
difficult to play without possessing the original game materials. This document proposes using the VASSAL
engine to simulate the use of the game board and paragraph booklets needed to play the game.
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Introduction
STAR SAGA: ONE Beyond the Boundary is a hybrid role-
playing/tabletop/computer game developed by Rick Dutton,
Walter Freitag, Andrew C. Greenberg, and Mike Massimilla
and released in 1988 for the Apple II/IIgs family of com-
puters, the IBM PC and its clones, and the Tandy 1000
[Mst88a]. Due to the scarcity of surviving physical copies
of the game and its reliance on a hefty set of non-digital
components (booklets, maps, etc), a present-day Apple II
user may miss the opportunity to explore this unique game
design.

One solution proposed here is to use the VASSAL En-
gine. VASSAL is a modern software system for playing com-
puterized adaptations of traditional tabletop board games.
It can be used to provide access to the non-digital compo-
nents, maintain the state of the game board, and allow a
multiplayer game to be conducted across the Internet (Play
by Email).

The purpose of this document is to guide the reader
through the steps involved in acquiring, configuring, and
using the software components needed to conduct a game
of STAR SAGA: ONE Beyond the Boundary using an Apple
II emulator and a STAR SAGA: ONE module for VASSAL.

1. Historical Context
1.1 Real-World Role-Playing Games
By the late 1970’s and early 1980’s, role-playing games such
Dungeons & Dragons had become a cultural phenomenon.
Some people began finding ways to take the role-playing
game out into the real world. At MIT, participants in the
Assassins’ Guild played both the role of hit man and target
with the campus providing the game’s boundary. In 1981,
a group in Boulder, Colorado asked the authors of Dream
Park, a science-fiction novel published the same year in-
volving immersive, hologram-fueled role-playing games,
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to adopt the name of the book’s the ruling committee, the
International Fantasy Gaming Society, as the name for their
own club.

1.2 Society for Interactive Fiction
It was in this environment that university students, Walter
Freitag, Michael Massimilla, and Rick Dutton, founded the
Harvard Society for Interactive Literature in 1982. This was
later shortened to the Society for Interactive Literature or
SIL. The group innovated a theatre-style form of role playing
game and in 1983 SIL began organizing weekend-long game
events called Rekon (Recon-1, Rekon-2, etc) which were
played at the Boskone science fiction conventions held in
Boston. Two years later SIL would begin to host their own
annual event, SILiCON, which, as of 2014, continues as
Intercon [OD98].

1.3 From SIL to Star Saga
Just before Rekon-2, Michael Massimilla, had a chance en-
counter with Andrew C. Greenberg, creator of the Wizardry
series of computer adventure games, when both competed
in a bridge tournament. Massamilla introduced Greenberg
to Dutton and Freitag. This led to Greenberg attending
Rekon-2 and sparked the idea to capture the experience in
the form of a computer game. So Dutton, Frietag, Green-
berg, and Massamilla set out to create a trilogy of computer
role-playing games using some of the elements of Rekon.
The first game of the trilogy was STAR SAGA: ONE Beyond
the Barrier [Mst88b].

1.4 Critical Reception
Reviews of the game ranged from favorable to enthusiastic
with the highest accolades coming from Computer Gaming
World. Here are excerpts from several computer and game
magazines that reviewed STAR SAGA: ONE - Beyond the
Boundary:

...Star Saga is a genre-buster. It can be com-
pared to no other game on the market. The best
way to describe Star Saga’s playing experience
is to compare it to participating in the Founda-
tion series of books by Issac Asimov. We’re
talking grand scale adventure here, folks.

(Com-
puter Gaming World August 1988 - pp. 30)

???1/2 (of 5)
Patience, the ability to read text and instruc-
tions, and a willingness to use the computer
only as a record keeper are the keys to this
game’s enjoyment. After the first few turns,
even the most addicted computerphile will en-
joy this text and book-based adventure.

(Dragon # 142 - pp. 48)

The game seems far more social event than a
computer game, for much of its entertainment

value comes from the interaction between play-
ers, not between human and computer.

(Compute! August 1988 - pp. 60)

CGG’s Special Award for Literary Achieve-
ment goes to Masterplay for Star Saga One:
Beyond the Boundary - [Ed: This is the first
time CGW has ever given an award for the fic-
tion presented in a computer game. Star Saga
One is the most marvelously well-written ad-
venture game ever presented on a computer.
Although the game lacks any on-screen graph-
ics, sound effects, or technical chrome, this hu-
morous, challenging, frustrating, exciting, and
addictive game holds its own as a benchmark of
adventure gaming on the computer.] (Com-
puter Gaming World October 1989 - pp. 8)

2. The Game
2.1 Overview
STAR SAGE: ONE Beyond the Boundary is a turn-based,
science fiction-themed game for one to six players. Each
player chooses to be one of six available characters. The
characters travel between different planets to trade goods, ac-
quire resources, improve their spacecraft’s capabilities, and
progress through the game’s narrative. A text-only program
called the Computer Game Master (or CGM) maintains the
game’s state. Players plot their moves using colored stone-
like tokens on a game-board map and take turns entering
their actions into the CGM. The program returns the re-
sults. Often this requires having the player read one or more
narrative passages found in a set of thirteen booklets.

2.2 Object of Game
The players are assigned a set of goals unique to their chosen
characters. These goals are intended to remain undisclosed
to the other players and can only be completed by exploring
and interacting with the game’s universe. The game is won
for the player when the character has completed its assigned
goals. Play can continue for the other players who have not
yet completed their goals.

2.3 Original Game Components
The original game included many physical components.
(See figure 1.) It would be meaningless to play the game
without possessing these items (or facsimiles of these items).

• (1) Host Guide / Player Reference Manual
• (1) small map used during the tutorial phase
• (1) large map used after the tutorial phase (not shown

in figure 1
• (6) Colored tokens to indicate players’ locations on

map
• (6) ”Dear Player” cards - starting point for the game
• (6) Character biographies / tutorials
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• (2) 5.25” or (1) 3.5” floppy diskette
• (13) Paragraph narrative books (labelled A-M) con-

taining entries numbered 1-888
• (1) Computer system instructions

3. Software Components Needed

3.1 Overview
To conduct a game of STAR SAGA: ONE Beyond the Bound-
ary using digitized game components will require these
items.

• The VASSAL Engine
• The VASSAL module for STAR SAGA: ONE
• Apple II or IBM PC DOS emulator
• Disk images for STAR SAGA: ONE

3.2 VASSAL
The VASSAL Engine is a contemporary, open source, cross-
platform software system that enables people to play tradi-
tional tabletop board or card games by email or across the
Internet. Modules for specific board games are downloaded
from the Internet and added to your VASSAL game library.

There is no artificial intelligence inherently provided by
VASSAL. The purpose for the system is to provide board
game hobbyists a way to play against others without geo-
graphic restrictions. Initially created to enable play-by-email
games of Advanced Squad Leader, over time the engine has
been generalized to support a vast number of games through
community-created game modules.

VASSAL provides a graphical user interface for man-
aging installed modules. Modules will normally contain a
facsimile of the game board, game pieces, and/or cards. The
movements of game pieces or the playing of cards, along
with text-based chats are stored into a log file that is shared
with the opponent. The opponent is able to play back the
log file to advance the game to its current state, then record
his/her own turn to be shared with the original player. And
thus, log files are traded back and forth to progress the game
to its conclusion.

3.3 Game Master Program
The tokens, game board, and narrative booklets provide the
majority of the game’s experience for the players. However
it is STAR SAGA: ONE’s Game Master program that man-
ages the details of the game. It generates random events,
provides an interface for players to enter their moves, returns
the results of player actions, coordinates trades, etc.

The Game Master program was available for the four
platforms listed in Table 1.

3.4 Emulator
To host a game of STAR SAGA: ONE requires running the
Game Master program on a real or emulated computer.
When playing a solitaire or multiplayer game where all

Table 1. Game Master Platforms

Computer Operating System Media

Apple II ProDOS 8 (2) 5.25” diskettes
Apple IIgs ProDOS 16 (2) 3.5” diskette
IBM PC MS-DOS 5.25” or 3.5” diskettes
Tandy 1000 MS-DOS

participants are at the same physical location, then you are
free to choose to run the Game Master program on a real
computer or your favorite emulator and operating system.

If organizing a multiplayer game to be played via email,
you must select an emulator that that satisfies two condi-
tions:

1. the emulator includes a save state feature
2. the emulator is available for all participants’ platforms

/ operating systems

These two requirements are necessary because the Game
Master’s save function is only accessible at the start of each
turn. Once any player begins their turn, the save game
function is not available again until all the players have
plotted their moves. See Table 2 for a list of commonly
used emulators and whether a save state feature is currently
available for each.

Table 2. Emulators capable of executing the Game Master
program

Emulator Target Native OS Save State

Virtual II II OSX X
AppleWin II All1 X
JACE II All –2

Linapple II Linux X
Sweet 16 IIgs OSX –
Kegs/GSport IIgs Linux/OSX –
DOSBox PC All X3

1. Using WINE under OS X or Linux
2. Possibly under development
3. Using Game Wizard Pro 32 Utility and Microsoft

MS-DOS

4. STAR SAGA: ONE Game Mechanics
in VASSAL

4.1 Overview
This section concentrates on reviewing the game mechanics
employed in the original game, such as player movement,
taking notes, etc. and comparing these to each one’s counter-
part as implemented within the VASSAL module for STAR
SAGA: ONE.
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Figure 1. Original Game Components

4.2 Game Maps and Player Tokens
Two poster-like game maps were included with STAR SAGA:
ONE. The smaller one, titled ”Starweb” is used only during
the tutorial phase. The larger map, titled ”Document Two”,
is used throughout the remainder of game play. Each space
on the map is defined by a colored and uniquely numbered
triangle (or ”trisector” in the game’s idiom). Most trisectors
are void. A few contain planets.

Each player’s current location on the map is marked
by the placement of a stone-like token within the boundary
of a trisector. (See figure 2). In the original game, the as-
signment of colored tokens to player characters is arbitrary;
players may choose any token to represent their characters.
However in the VASSAL module, each of the token colors
have been assigned to a specific character. A cross reference
between token color and player character is available by
clicking on the Help → Player Tokens menu items. (See
figure 3 and figure 4).

Movement of player tokens on the map is only allowed
from the current trisector to one of the three immediately
adjacent trisectors that share the sides of the triangle (not the
vertices). Through a clever distribution of colors across the
trisectors, an unambiguous path can be described given the
current trisector and an ordered list of the colors along the
route. (See figure 5). Player movements on the gameboard
must also be entered in the Computer Game Master program.
Only legal moves will be allowed by the CGM program.

4.3 Plotting Sheet
If you were conducting the original game with multiple play-
ers sharing the same computer, it would become apparent
a need exists to minimize a player’s time at the terminal. It

Figure 2. Gameboard and tokens within VASSAL

is not the place for the player decide which moves to make.
Instead the game’s designers recommend planning the next
move while away from the computer and writing down the
intended moves on a piece of paper. (See figure 6). This
way, the player only needs to enter the moves and obtain
results when it is his his/her turn at the terminal.

To simulate this, a virtual Plotting Sheet is available in
the STAR SAGA: ONE VASSAL module and can be found
by accessing (right-clicking) the context menu bound to a
player’s token. (See figure 7). A simple spreadsheet will
appear where moves can be entered. (See figure 8). On
first use, you may be required to enter column headers and
row numbers. The VASSAL engine will save the spread-
sheet contents as part of the log file and can be recalled and
appended on later turns.
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Figure 3. Click on Help→ Player Tokens to review token
assignment

Figure 4. Cross-reference between token color and
character available in the VASSAL module

4.4 Cargo Sheet
At the start of the game each player’s ship has the capacity
to store ten units of cargo. The Computer Game Master
will maintain the current state of cargo. But you can also
make note of it within VASSAL by accessing the Cargo
Sheet from your token’s context menu. (See figure 9). A
free-form spreadsheet will appear where you can enter data
as needed. (See figure 10).

4.5 Items and Abilities
Similar to the Cargo Sheet, another free-form spreadsheet
is available from your player token’s menu for recording
special items and abilities gained during play. Use this as
needed.

Figure 5. An example path described as 114 to Orange,
Violet, Green, Yellow, Red

Figure 6. Example of plotting turns 1 and 2 as found in the
original manual

4.6 Passage Finder
The original game included thirteen booklets labelled A
through M, containing passages numbered 1 through 888.
Throughout much of the game, the Computer Game Master
will instruct a player to read a specific passage from one of
the books. These passages form the game’s narrative.

The VASSAL module contains scans of these passages
created by an early abondonware/archival group called The
Underdogs and a user named Ranger55[?]. They devel-
oped a javascript program to retrieve individual passages
requested by the player. In VASSAL, select Help→ Pas-
sage Finder to open the Passage Finder tool (see figure 11).
Then enter the requested passage number in the text box on
the form (see figure 12). Whenever necessary, enter passage
000 to return to the title page.

4.7 Planet Log
Much of playing STAR SAGA: ONE involves trading goods
between planets. Planets may also provide opportunities to
perform actions, such as searching through a junkyard for
special items. The game’s designer’s recommend creating a
planet log on paper to record the exchange rates for goods
and the special activities available for a particular planet.

Virtual planet log sheets are available in the VASSAL
module. As described in more detail later, you will pull
a new Planet Log game piece for each planet visited. In
order to keep Planet Logs private between players, a Planet
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Figure 7. Accessing the Plotting Sheet menu item in
VASSAL

Figure 8. Example of plotting turns 1 and 2 using VASSAL

Log piece placed on the map is accessible only to its owner.
For this reason, a separate palette exists for each character.
Select the palette for your character before adding a new
Planet Log piece to the game.

The game designers intended for the details for a particu-
lar planet to be known only to the players that have visited a
planet. Therefore, in the VASSAL module the Planet Label
game piece can be toggled to be invisible to other players.

Upon visiting a new planet, perform the following steps.

1. Click on the Planet Log button to toggle the display
of the Planet Log palette (See Figure 13).

2. Find the palette for your character.
3. Drag a new Planet Log game piece and drop it on

the game board on top of the planet you are currently
visiting.

4. Right click on the new Planet Log and select the ”Re-
name” menu item. Rename the log to match the planet
being visited. (See Figure 14).

5. Right click again on the renamed Planet Log and se-
lect the ”Planet Log” menu item. A blank spreadsheet
will appear.

6. Enter relevant information as required onto the spread-
sheet. (See Figure 15).

7. Right click again on the Planet Log and select Tog-
gle Visibility so that the Planet Log is not visible or
accessible by other players.

4.8 Planet Labels
After the tutorial phase is complete, the larger map, labeled
Document Two, is used for the remainder of play. The
Document Two map contains many yet-to-be-discovered
planets denoted as black dots. To provide replayability,
the Computer Game Master program will randomly assign

Figure 9. Accessing the Cargo Sheet menu item in
VASSAL

Figure 10. Cargo Sheet in VASSAL

planets to map locations at the start of each new game. Once
a planet is visited, the players will discover its name. The
original documentation instructs players to lightly write the
name of discovered planets using a pencil on the Document
Two map.

Unlike the details found in the Planet Log, the name
of the new planet is intended to be shared with all players.
Therefore, within VASSAL, a game piece called a Planet
Label is used as a way to virtually write the planet name on
the map.

Upon discovering a new planet, a player should perform
the following actions in VASSAL:

1. Click on the Planet Label button in VASSAL’s toolbar
area so the Planet Label palette is visible. (See figure
16)

2. Drag the Planet Label game piece (currently with the
label ”New Planet” from the planet to the black dot
on the map (See figure 17)

5. How to Conduct a Multi-Player Game

5.1 System Preparation
1. Download and Install the VASSAL engine

2. Download the STAR SAGA: ONE module for VAS-
SAL

3. Open the STAR SAGA: ONE module in VASSAL

(a) Click File→ Open Module

(b) When the Welcome splash screen, Click Cancel

4. If Play-by-Email then it’s recommended to install
AppleWin emulator
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Figure 11. Accessing the Passage Finder tool from the
VASSAL Help menu item

Figure 12. Passage Finder tool

(a) Download AppleWin

(b) If Mac OS X Mavericks then install WINE

i. Install XCode from App Store
ii. Enable command line tools in XCode

A. From Terminal, run
xcode-select --install

iii. Install MacPorts for OS X Mavericks
iv. Update MacPorts

sudo port selfupdate

v. Install WINE using MacPorts
A. From Terminal, run

sudo port install wine-devel
sudo port install winetricks

vi. Install Windows MFC 4.2 for WINE
A. From Terminal, run

winetricks mfc42

vii. Test AppleWin
A. From Terminal, run

wine <path-to-exe>/Applewin.exe

where <path-to-exe> is the path
to the directory containing the Applewin.exe
executable file.

(c) If x86 Linux then install WINE

i. From Terminal, run
sudo apt-get install wine-devel
sudo apt-get install winetricks

Figure 13. The Planet Log button in the toolbar (A) toggles
the display of the Planet Log palette (B)

Figure 14. After dragging a new Planet Log piece to the
gameboard, right click to access its context menu

ii. Install MFC 4.2 for WINE
A. From Terminal, run

winetricks mfc42

iii. Test AppleWin
A. From Terminal, run

wine <path-to-exe>/Applewin.exe

where <path-to-exe> is the path
to the directory containing the Applewin.exe
executable file.

5.2 Initial Setup
1. Launch Apple II Emulator

(a) Load STAR SAGA: ONE disk images in VAS-
SAL

i. Insert image for STAR SAGA: ONE DISK
A BACK into S6D1

ii. Insert image for STAR SAGA: ONE DISK
B FRONT into S6D2

(b) Boot Apple II
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Figure 15. Example of data entered into the Planet Log
spreadsheet

Figure 16. Click on the Planet Label button (A) to toggle
the display of the Planet Label palette.

5.3 Player 1 - Turn 1
1. Launch VASSAL

(a) Open the STAR SAGA: ONE module in VAS-
SAL

i. Click File→ Open Module
ii. Browse to the directory containing the STAR

SAGA: ONE module
iii. At the Select Play Mode prompt, choose

Start New Game and click Next
iv. At the Choose Side prompt, select a char-

acter to be used by Player 1 and click Next
v. At the Select Board prompt, choose the

map named Map 1 (Starweb) and click Fin-
ish

(b) Click Help→Manuals and Dossiers and read
the Host Guide and Player Reference

(c) Click Help→Manuals and Dossiers and read
the Dear Player Card

(d) Click File → Begin Logfile to start recording
any moves

(e) Click Help→Manuals and Dossiers and read
the Player 1 character’s biography

(f) As you read the biography, you will be taught
how to use the game system. Use the VASSAL

Figure 17. Accessing the Cargo Sheet menu item in
VASSAL

features described earlier in the document (Plot-
ting Sheet, Planet Log, etc) and the Computer
Game Manager running on the Apple II as in-
structed.

2. Switch to the Apple II Emulator

(a) When your turn is complete within the Com-
puter Game Manager, save the state of the ses-
sion using Save State feature of the emulator.
(On AppleWin, it is found under the Advanced
tab in the AppleWin Configuration dialog.) Note:
AppleWin will work best if you save the state
file in the same directory as the STAR SAGA:
ONE disk images.

3. Switch to VASSAL

(a) When your turn is complete, click File→ End
Logfile and save the logfile to a convenient loca-
tion, such as a ”Saved Games” folder. Be sure
to name the file that somehow encapsulates the
turn and move, such as TURN001M1.vlog.

(b) Exit the STAR SAGA: ONE module and return
to the VASSAL Module Library dialog.

(c) Right-click on the STAR SAGA: ONE entry in
the Module Library dialog and select Add Saved
Games Folder. Browse to the location where
you saved your logfile.

4. Share Files

(a) Share the log file TURN001M1.vlog and the
AppleWin save state file with the other players
in the group using email or a file-sharing service
such as Dropbox.

5.4 Player 2 - Turn 1
1. Obtain the log file TURN001M1.vlog created by the

first player and store it in a convenient location, such
as a directory called ”Saved Games”.
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2. Launch VASSAL

(a) Open the STAR SAGA: ONE module in VAS-
SAL

i. Click File→ Open Module
ii. Browse to the directory containing the STAR

SAGA: ONE module

(b) At the Welcome screen, select the radio button
labelled Load Saved Game and click Next. (See
figure 18).

(c) On the next screen, browse to the location of the
saved games and select the log file TURN001M1.vlog
and click Open.

(d) Back at the Welcome screen, click Finish.

(e) After the game board appears, adjust the scale as
needed using the zoom-in or zoom-out buttons
in the VASSAL toolbar.

3. Launch Apple II Emulator

(a) Load the state file created by Player one. (The
load state button is found in the Advanced tab
under the AppleWin configuration dialog.) It’s
best if the state file is located in the same direc-
tory as the disk images. Also, ensure the files
for the disk images have the same name as used
by Player one. Otherwise the state file may be
confused when it can’t find disk images.

4. Switch to VASSAL

(a) Play back Player one’s moves by clicking on
the ”Play” button found in the toolbar. Alter-
natively, you may press the Page Down key on
your keyboard.

(b) At the end of the log file, a dialog appears asking
to start a new logfile. Answer affirmatively. (See
figure 19).

(c) Click Help→Manuals and Dossiers and read
the Player 1 Character’s Biography

(d) As you read the biography, you will be taught
how to use the game system. Use the VASSAL
features described earlier in the document (Plot-
ting Sheet, Planet Log, etc) and the Computer
Game Manager running on the Apple II as in-
structed.

(e) When your move is complete, click File→ End
Logfile.

5. Switch to the Apple II Emulator

(a) When your turn is complete within the Com-
puter Game Manager, save the state of the ses-
sion using Save State feature of the emulator.

(On AppleWin, it is found under the Advanced
tab in the AppleWin Configuration dialog.) Note:
AppleWin will work best if you save the state
file in the same directory as the STAR SAGA:
ONE disk images.

6. Share Files

(a) Share the log file TURN001M1.vlog and the
AppleWin save state file with the other players
in the group using email or a file-sharing service
such as Dropbox.

Figure 18. Radio Button for Load Saved Game

Figure 19. Dialog box that appears at the end of playing
back a log file

5.5 Player 3 through N - Turn 1
If you have more than two players participating in the game,
the remaining players should follow the instructions for
Player 2 - Turn 1, with the exception that they must:

1. Load the most recent save-state file in the AppleWin
emulator.

2. Play back the log files, in sequence, created by each
of the previous players. To play back more than one
log file, click File→ Load Continuation and select
the next log file.

5.6 Player 1 through N - Turn 2 through N
Similar to the instructions for Player 3 through N - Turn
1, in Turn 2 and thereafter, each player should:

1. Play back all the log files, in sequence, created by
each player since the current player’s previous turn.
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6. Resources

Table 3. Disk Image Resources

Computer Resource URL

Apple II disk image ftp://ftp.apple.asimov.net/pub/apple ii/images/games/rpg/misc/STAR SAGA ONE DISKA FRONT.dsk
disk image ftp://ftp.apple.asimov.net/pub/apple ii/images/games/rpg/misc/STAR SAGA ONE DISKA BACK.dsk
disk image ftp://ftp.apple.asimov.net/pub/apple ii/images/games/rpg/misc/STAR SAGA ONE DISKB.dsk

Apple IIgs disk image ftp://ftp.apple.asimov.net/pub/apple II/images/gs/games/adventure/Star Saga One.zip
disk image ftp://ftp.apple.asimov.net/pub/apple II/images/gs/games/adventure/Star Saga Two.zip
scans http://mocagh.org/loadpage.php?getgame=starsaga

JVM VASSAL http://www.vassalengine.org/
module http://www.vassalengine.org/mediawiki/index.php?title=Category:Modules&from=S
or http://bit.ly/star saga one module
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